Home > Driver Is > Driver Is Incapable Of Supporting The Current Environment Attributes

Driver Is Incapable Of Supporting The Current Environment Attributes

The infocenter rather unhelpfully says (for an application migration) Quote: 8. Is this correct? Download the report Question has a verified solution. You must use an OdbcCommand: http://msdn.microsoft.com/en-us/library/system.data.odbc.odbccommand.aspx Darrell Norton, MVP Darrell Norton's Blog Please click "Mark as Answer" if this helped you. useful reference

Does this makes sense? more stack exchange communities company blog Tour Start here for a quick overview of the site Help Center Detailed answers to any questions you might have Meta Discuss the workings and ODP.Net is so much better and a native access provider. 0 Message Author Comment by:HugoMartins ID: 382468242012-08-01 A thought that crossed my mind. Should I disclose a 'learning disability' (dyslexia) to my employer?

The error has the following diagnostic information: SQL State ''IM004'' SQL Native Error Code '0' SQL Error Text ''[DataDirect][ODBC lib] All rights reserved. Creating ODBC works OK, but when I try to link a table to Access, I receive the following error: [Microsoft][ODBC Driver Manager] The driver is incapable of supporting the current environment

  1. You can install the DB2 client separately into a new location and then catalog the existing v8.x databases into that client as if they were remote databases.
  2. I have the ODBC 5.0.4 install set, that's why I must have thought I was using it, but now I'm sure I wasn't.
  3. Reply With Quote 08-01-12,12:34 #5 HugoMartins View Profile View Forum Posts Registered User Join Date Aug 2012 Posts 4 Sorry but I'm not understanding your question.
  4. What I'm trying to find is the misconfiguration.

However, if you find bugs with the functionality listed above, then we’ll be working to address those issues in the next milestone release (if possible). For most folks, they don't know, what they don't know. The ODBC return code was '-1'. share|improve this answer answered Aug 2 '12 at 9:03 Richard Spencer 417512 Tried tracing the ODBC (both the 64 and 32 bit) but only got empty files.

Thank you for any hints Back to top smdavies99 Posted: Fri Mar 18, 2011 2:24 am Post subject: Re: mqsimigratecomponents fails because of ODBC issues Jedi CouncilJoined: 10 Feb 2003Posts: 6073Location: If you unexpected have already this problems, feel free to open it again. How to repeat: - setup MySQL 5.0 (mysql-5.0.24a-win32-setup.exe) - setup mysql-connector-odbc-noinstall-5.0.4-alpha-win32 - set database privileges and use OLD_PASSWORD function - create an ODBC link to a database - try to link svu wrote: Both versions 6 and 7 are using same odbc.ini, with the lines Therein lies your problem Could it be that the V7 broker uses a different Datadirect driver?

ERROR [HY010] [Microsoft][ODBC Driver Manager] The driver is incapable of supporting the current environment attributes. Did you have any problems setting up the ODBC data source ? –Richard Spencer Aug 2 '12 at 13:31 No problems, and both test buttons give success messages. –MadCatPT If you need to connect to an unsupported database, you can install a supported database client and then rely on the support the database provides to talk to the unsupported version. This document resolved my issue This document did not resolve my issue This document helped but additional information was required to resolve my issue What can we do to improve this

Could it be that it was MyODBC 3.51.xx after all? [13 Sep 2006 10:30] Oszkár Horváth Dear Tonci! It's not a perfect solution, neither the real root cause of the error was found, but my main concern was to be able run the application locally, 0 Featured Post Three Not the answer you're looking for? The error has the following diagnostic information: SQL State ''HY010'' SQL Native Error Code '0' SQL Error Text ''[DataDirect][ODBC lib]

Am I missing something? For most folks, they don't know, what they don't know. What makes a poem a poem? Should upgrading ODBC driver to the newer version be enough?

Your problem shouldn't occur there. Back to top svu Posted: Fri Mar 18, 2011 2:32 am Post subject: VoyagerJoined: 30 Jan 2006Posts: 99 I tried to change lib to lib64, got another error: Code: BIP2322E: Database We have queried this with IBM, since upgrading to DB2 v9 (immediately before removing the need for it) is not our preferred option. this page Join them; it only takes a minute: Sign up ERROR [HY010] [Microsoft][ODBC Driver Manager] Ask Question up vote 0 down vote favorite I get this error: ERROR [HY010] [Microsoft][ODBC Driver Manager]

Reply With Quote Quick Navigation Oracle Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums Non-SQL Forums MongoDB Database Server Software Adabas DB2 Informix Microsoft SQL Windows OS Windows 7 Introduction to using the Windows 10 Snipping Tool Video by: Andrew In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how Learn how to help fight scammers by beating them at their own game.

If you are experiencing a similar issue, please ask a related question Security Patches - To Patch or Not to Patch? - That is the question!

Do you have error of commission or error of omission? Thanks for your competent and fast help! Last edited by HugoMartins; 08-01-12 at 12:36. The website runs, only when accessing certain pages that use those ODBC it fails.

I am using crystal reports 10. But anyway, you made a valid point about supported DB2 versionLast edited by svu on Fri Mar 18, 2011 3:29 am; edited 1 time in total Back to top zpat Posted: I'm getting really frustrated with this. I tried also replicating the error with the trace from the ODBC manager, first with the 64 then with the 32, and as I wrote before the trace files where empty.

This tool uses JavaScript and much of it will not work correctly without it enabled. My collegues have the same setup but never seen the error, we've been trying to solve it for two days, any help is welcome. Any tips to help me find the cause of the problem? ‹ Previous Thread|Next Thread › This site is managed for Microsoft by Neudesic, LLC. | © 2017 Microsoft. Re: ODBC error when trying to connect to TimesTen server ChrisJenkins-Oracle Aug 12, 2016 7:01 AM (in response to f23cec54-97af-49c4-9030-98fb745e4798) I have never seen this error before.

So if you can get it from Passport Advantage it will be under a db2 entitlement not your broker entitlement. You had to install your own stuff? Take our survey and automatically be enter to win anyone of the following: Yeti Cooler, Amazon eGift Card, and Movie eGift Card! Reply With Quote 08-01-12,11:54 #2 anacedent View Profile View Forum Posts Registered User Join Date Aug 2003 Location Where the Surf Meets the Turf @Del Mar, CA Posts 7,776 Provided Answers:

This great pass time helps the world, while providing an endless source of entertainment. I'll try some other versions, and to find more information. 0 LVL 77 Overall: Level 77 Oracle Database 76 .NET Programming 9 ASP.NET 9 Message Active 1 day ago Expert This assumes of course that db2 v9 can catalog the relevant v8.x databases. So, it is libdb2Wrapper.so after all, on Solaris.

Join & Ask a Question Advertise Here Enjoyed your answer?